ssstanton

Plugin works in VS2010/NET4 but not VS2008/NET3.5

Discussion created by ssstanton on Jun 29, 2011
Latest reply on Jun 30, 2011 by jihua816
I recently moved some plugin code from an (ArcGIS 9.2 + VS2005 + NET2 + XP 32bit) environment to (ArcGIS 10.0 + VS2010 + NET4 + Win7 x86 build on 64-bit machine). In the process, I included a build-event to run ESRIRegasm on the assembly containing my plugin. Everything worked fine.

Now I'm trying to do a build using (ArcGIS 10.0 + VS2008 + NET3.5 + Win7 x86 build on 64-bit machine). The application builds ok, but the call to IWorkspaceFactory.Open comes back with an exception (without any further explanation).

I've had a look at the files produced by ESRIRegasm, and the VS2010/NET4 result is identical to the VS2008/NET3.5 result. I've also tried running as admin.

I then tried the SimplePointPlugin sample to see if that would work. And unfortunately, it did! Which leaves me somewhat mystified.

Has anyone confronted similar issues with plugins?

Outcomes