dougbrowning

PointDensity Tool will not run in script in v10

Discussion created by dougbrowning on May 13, 2011
Latest reply on Oct 23, 2012 by nilsbabel
So i am updating a python script i wrote in 9.3 to v10.  For some reason it keeps giving me a 582 error - which means the parameters are not valid.  The parameters did change a lot in v10 (why I do not know) including not taking the output raster name as a parameter (weird).

So I made the appropriate changes with no luck.  I even took out ALL parameters but the two required ones and it still will not run.  I have tried everything.  It is not a extension problem as I tested that and it gives a different error.  i already tried _sa, etc with no luck.

here is the simplified call

import arcpy, sys, os
from arcpy.sa import *

arcpy.Merge_management(fileList, mergeName)

# Check out ArcGIS Spatial Analyst extension license - need for v10
arcpy.CheckOutExtension("Spatial")
print "here1"

# Run density tool with given params
print "here2"
myNbrCircle = NbrCircle(int(radiusSize), "MAP")
print "here25"
tmpRast = PointDensity(mergeName, "NONE")
print "here3"

It prints here25 but not here3.  i know in other scripts it was an issue with having to use make feature layer first for some reason but I tried that with no luck.  I dont have that script to check the exact steps.  there is nothing in the help about feature layer versus feature class which was the issue before.  Esri sure likes the word feature.

Any help is appreciated.  I just want get it to run simple then I will add in the new Nbr and such.

This is the 9.3 call that worked just fine
gp.PointDensity_sa(mergeName, "NONE", rasterName, int(cellSize), "Circle " + str(radiusSize) + " Map", "ACRES")

Outcomes