DOJO and layers not loading

Discussion created by mirvin on May 11, 2011
Latest reply on May 24, 2011 by mirvin
Being new to ESRI, even newer to the ESRI on the web, and yet even newer to REST and Dojo, I give up and now seek advice.

My situation:  MS Server 2003 outside the firewall, MS SQLServer 2008 inside the firewall, ESRI Server 9.3.1 inside the firewall.  IIS with dot NET on both servers.  I???ve tried all three on the inside but because I need Cold Fusion and that???s on the outside, I???m left with this setup.  Oh, and ESRI Server and MSSQLServer 2008 on same computer.  Local Admin on both servers and db admin.

To the problem.  I have three frames left to right, control panel, map, result panel.  Everything works but the map doesn???t load layers.  If I go through the ArcGIS Services Directory and View in ArcGIS JavaScript, I can see the loaded layers.  I have used example codes to show coordinates, electable layers, and navigation.  None of these load.

Now the fun part???If (while not closing all of the browser instances and after viewing in ArcGIS JavaScript) my three frame Map now works.  If I close all browsers down and try to load the three frame website, layers will not load again.

I???m 99 percent sure it???s not the coding.  I???ve used their examples and applied my URL and it does the same thing.  I???ve tried, I swear, every combination of permissions.

BTW, and I???m not real confident of cause and effect, but watching services on the server, a new service didn???t start until I loaded from the ArcGIS Services Directory.  May have been a coincidence.  My three frame wouldn???t start a new service.

What am I missing?