AnsweredAssumed Answered

Problem when using geometryEngine: "TypeError: Unable to get property 'G' of undefined or null reference"

Question asked by FranPicDK on Oct 15, 2020

Hi all,

Working here with the 4.17 API, I am trying to use the geometryEngine to check if 2 geometries intersects. The first geometry is a point and the second one is a polyline. Using the 'intersects()' or the 'crosses()' method of the geometryEngine, I am getting this weird error that I don't understand:

 

TypeError: Unable to get property 'G' of undefined or null reference

 

 

I don't manage to find anything on the net nor in the API reference explaining this error. I basically followed this tutorial.

 

 

I tried several experiments and some additional information:

 

- I checked that the spatial reference was the same for both geometries. I am working with wkid: 102100 for both geometries.

- The point geometry's latitude and longitude are set but x and y are undefined. I don't know if it is relevant.

- Following the aforementioned tutorial, instead of using directly the geometry itself, I used a buffer using the 'geodesicBuffer()' method of the geometryEngine.

The error is the same when the point geometry (without buffer) and the polyline geometry buffer are used.

Nevertheless, when using the point geometry buffer with the polyline geometry either with or without buffer, I am getting the other weird error caused by calling the 'geodesicBuffer()' method of the geometryEngine to generate a buffer from the point geometry:

 

TypeError: Object doesn't support property or method 'u'

 

 

Does this ring a bell for anyone?

Outcomes