AnsweredAssumed Answered

Info captured in Repeat not displaying when creating a new Survey from existing Feature Layer

Question asked by MondiSA on Oct 13, 2020
Latest reply on Oct 13, 2020 by ccounsellesriaustralia-com-au-esridist

Hi there

 

I have a survey which captures observations/incidents in-field that then need to get looked at and potentially actioned for correction. I have a repeat block in my survey where i have 2 select multiple questions and then a point capture and file upload question.

 

I have created another survey from the same feature class to use as a survey where these observations can be actioned or rejected. I populate the Inbox of this survey depending on whether it has been actioned yet or not. When I click on one of the surveys in the Inbox to open it up to view the observations, I can see all captured info for the rest of the survey, but the repeat block is empty and looks like this. I need to have this info exposed as well so that the manager can see if observation needs attention. I have set fields to read only in the close out survey, so that is why they are greyed out (everything is blank)

 

Why would my repeats not be displayed in this survey that was created from an existing feature class? In the original survey I can see everything if I go to the Sent folder and open the submitted survey.

 

I have uploaded both the initial survey XLSX and the newly created one from the feature service. Maybe there is something you can all see that i am missing?

 

Thanks so much!

 

Paul

Ismael Chivite James Tedrick 

 

 

PS: OK, after much reading I figured out that I need to put "query" in the  bind::esri:parameters column of the begin repeat row. This will then in the Inbox expose the information captured in the repeats. I do however notice that if i upload a JPEG, it wont be displayed. I am assuming that is because i used the question for uploading as being FILE. I am assuming that if i had used the IMAGE type then it would be displayed?? (Just tried IMAGE and it still doesn't display image)See below:

 

Why would the image not be displayed?

 

I hope this can help others

Outcomes