AnsweredAssumed Answered

"Layer did not draw completely" unless editing is enabled with NaN m-values

Question asked by AthensGIS on Oct 8, 2020
Latest reply on Oct 13, 2020 by AthensGIS

EDIT: NaNs for m-values seem to be the culprit. After moving the features to a class with m-values disabled, everything is drawing properly.

 

The feature class that is drawing correctly is the route layer for a (now deprecated) linear referencing system. All the m-values are correct. I moved away from the LRS for our street model because ArcGIS Pro lacks good editing features for LRSs, but I left the m-values. After making edits to the routes, there were vertices with NaN m-values. Those NaN m-values seem to cause this drawing issue.

 

Original post:

 

I have a layer of street centerlines that is not drawing beyond the 200ft scale in an AGOL web map when editing is turned off or in a view layer. It does draw at small scales when editing is enabled. In the Visualization tab for the feature layer, the entire layer is drawn correctly. I have tried the layer as multipart and single part features. I have tried turning on optimized layer drawing (and it has been multiple hours since, so I assume that is complete). As single part there are 531 features with a total of 24,932 vertices, and the largest single line vertex count is 725.

 

A few months back I uploaded a very similar feature layer (the layer's local source was corrected, and that corrected layer is the one causing problems) with nearly identical features. This layer has 391 multipart features with 24,796 total vertices and a single line vertex count max of 1,047. This layer draws at all scales and never had optimized layer drawing enabled. This layer works with editing on or off and has a functional view layer.

 

Have I misconfigured my feature layer somehow?

 

Here is a map with both the view layers: https://arcg.is/1WXWCr 

Tested in Chrome and Edge.

Outcomes