AnsweredAssumed Answered

How do i change the filetype in the filebrowser for Spatial ETL Tools?

Question asked by stephanyclemens on Sep 30, 2020

Hello there!

 

A while ago i started to create Spatial ETL Tools in ArcGIS Pro with the FME Workbench to fetch Data from the local WFS. After getting used to it, i started to use a lot of PythonCaller in my tools to unify the diffrent queries. I end up with three solid queries, which, when imported as toolbox, fetch the GDB-Path and the additional information (2 coordinates or a number or name for a specific area) . The browser for the GDB-Path is working, even though is a little bit weird that Projecttab: Database -> default.gdb yield the path C:\...\Projectfolder\default.gdb\\GDB\default.gbd. To retrieve the correct GDB-Path you have to go this way: Projecttab: Folders -> Projectfolder -> default.gdb. This result gets you C:\...\Projectfolder\default.gdb. I don't why the first way doesn't work, since its the same database.

 

But anyway, the real problem lies within the second information the user puts in. In this new query i want to request multiple features. But to use the stored queries from the server, i need to do one HTTP-Call for every feature. To make it for my colleagues as easy as possible, the input is an Excel-Sheet they can fill out. The PythonCaller then constructs the string needed for the stored query.

 

To get the path to said Excel-Sheet, i created a published Parameter in FME and defined it as below.

When i run the workspace, i can enter my parameters as usually. Everything works like a charm. Picture below.

So the tool was ready for deployment or so were my thoughts. But when importing the Spatial ETL Tool in ArcGIS Pro into a toolbox, my defined file-type isn't showing up. It just says Files.

I obviously want at least the Excel-Files to show up, only Excel-Files would be even better. Does anyone know what i did wrong? Can i somehow change the datatype to All Files in the ArcGIS Pro file explorer? Or is there another workaround?

 

To add, manually entering the link does work, but then again i can just use a string-parameter. I also tried using the Excelfile-reader, but i couldn't work out how to import a table in the PythonCaller.

 

Since its working in FME but not in ArcGIS Pro i didn't know what to do.

 

Thanks in advance and for for your time (reading the whole thing ),

Clemens

Outcomes