AnsweredAssumed Answered

ArcGIS Web Adaptor 10.8.1 (IIS) error accessing Portal machine

Question asked by stephen_k on Sep 29, 2020
Latest reply on Oct 18, 2020 by stephen_k

We have a base ArcGIS Enterprise deployment setup on a single machine on Windows Server. We recently upgraded it from 10.8 to 10.8.1 and checked that all components work as expected in the upgraded deployment. However, after the upgrade, the ArcGIS Web Adaptor (for IIS) configured with Portal for ArcGIS runs into the error described in this Esri technical article. That is, when trying to open any Portal item, the item page sometimes opens successfully, but often times, it returns the error described in the article.

 

"Could not access any Portal machines. Please contact your system administrator"

 

After reloading the failed item page a few times, it then loads correctly, usually after the third or fourth attempt. We've tried all the suggested solutions in the article but none have resolved the issue. These include: clearing the web browser cache, restarting the Portal for ArcGIS Windows service, repairing the Portal for ArcGIS installation, and even reinstalling Portal for ArcGIS. We've also tried uninstalling, reinstalling, and reconfiguring the Web Adaptor for Portal with the same configuration that worked perfectly in 10.8.

 

When Portal for ArcGIS is accessed directly through port 7443 (bypassing the Web Adaptor), this error does not occur. This suggests the issue lies with the configuration of the Web Adaptor. The Web Adaptor configuration used in 10.8.1 is the same that we used in 10.8, and we can access the Portal and sign into it using the Portal URL and administrator username and password that we've used in the Web Adaptor configuration. So, we're not sure what else might have changed during the upgrade to cause this error.

 

We've also looked through the Portal for ArcGIS logs in the Portal Administrator Directory but couldn't find anything related to this error. Are there any logs produced specifically by the Web Adaptor that can be examined to debug the cause of this error?

 

The error seen is as shown in the screenshot below:

 

Jonathan Quinn, if you have any helpful ideas on the possible cause of this error in Web Adaptor, we'd highly appreciate your feedback. Thanks.

Outcomes