AnsweredAssumed Answered

ArcGIS Enterprise Multi-machine Problems

Question asked by craig_johnson1 on Aug 10, 2020
Latest reply on Aug 19, 2020 by JQuinn-esristaff

I've been dealing with this problem for a while and have even asked questions on here about it but I have not found a solution yet.

 

I want to setup a multi-machine deployment on two virtual servers (Windows Server 2019);

Machine1 - Portal, ArcGIS Server, Data Store, Web Adaptor (I used Builder to install all software)

Machine2 - ArcGIS Server with Image Server license (just used ArcGIS Server installation software)

 

Everything loads fine, it's just when I load ArcGIS Server on Machine2 and it asks if I want to "Create a New Site" or "Join an Existing Site" I get the following error:

 

Failed to join the site 'https://MACHINE1:6443/arcgis/admin/'. Server machine 'https://MACHINE1:6443/arcgis/admin//machines/register' returned an error. 'Admin URL 'https://MACHINE2.GIS.COM:6443/arcgis/admin' is not reachable from 'MACHINE1.GIS.COM'.

 

 

I've done multiple installations (wipe the machine and start over) and always receive this error.

I've created Inbound and Outbound rules to open every port that ESRI recommends on both servers. I have a CA-Signed SSL certificate for both servers.  Both servers have a Fully Qualified Doman Name. I can ping each server. I can view the default IIS webpage from each server. I'm using the same ESRI license files for each server. I'm using the same version of ArcGIS Server on each machine (10.8). 

 

Basically, I've done everything I know to join Machine2 to the existing site on Machine1.

 

My question - is there anything else, no matter how trivial, that I should look at when setting up the servers. I feel it is a server issue that I'm overlooking, something very simple.  For example, should I worry about the Host file??

 

Any information would be appreciated.

Outcomes