AnsweredAssumed Answered

Shapefile with problems in ArcGIS Pro but not in ArcMap?

Question asked by felipe.caldas_NLC on Jul 26, 2020
Latest reply on Jul 27, 2020 by felipe.caldas_NLC

Hi all,

 

I have a polygon-based shapefile whereby when I drop it in ArcGIS Pro, it loads the geometry alright, but the label doesn't draw and when I create a new column in the attribute table and try to 'Calculate Geometry' I get this error: 000635: Skipping feature because of NULL or EMPTY geometry.—Help | Documentation 

Then, I run the 'Repair Geometry' and it fixes errors for every row. The only error is this one: 'Incorrect ring ordering at 0 in Poles_WGS84'.

Now that it was fixed, the label renders, for example.

Then, my next step is to calculate the X,Y,Z (calculate geometry) in the attribute table and export this table as DBF.

Next, I try to 'Display XY Data' from this table, I select the X,Y and Z and when I run the operation I get:

 

WARNING 100160: Some of the features have invalid geometry and have been removed from the result
WARNING 000192: Invalid value for rows 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22,

 

None of these errors happen in ArcMap 10.5, using the same shapefile as a starting point.

 

What am I doing wrong?

Thank you

Outcomes