AnsweredAssumed Answered

wrapAround180 map property with WAB

Question asked by vmbajop on Jun 23, 2020
Latest reply on Jun 24, 2020 by rscheitlin

I'm developing with JS 2D API 3.24 in WAB 2.8, in the framework of AGS 10.6.1.

I need a map with the property wrapAround180 set to true. This is not a property configurable in WAB. I'm trying to configure it writting the property in config.json, in entry "map", sub entry "mapOptions", below "lods", with something like this:

:

"map": {

"3D": false,

...

},

"itemId": "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx",

"mapOptions": {

   "lods": [

         {},

          ...

        {

            "level": 13,

            "scale": 1000,

            "resolution": 0.00000237

         }

   ],

   "wrapAround180": true,

   "extent": { ...

Nevertheless, when app is launched, the map has this property in false.

If in the same line of the config.json file I put the property "zoom": 4,deleting "wraparound180" property, then the map starts in zoom = 4. In others words: it must work.

The file config-readme.txt confirm that in "mapOptions" entry of config.json we can put same options as the map API options.

Debbuging, I can see that this property is true until _show2DWebMap method in MapManager.js file, in jimu.js folder of the App. In this method, map.wrapAround180 is false. I have chenged this value programatically and runs ok... until we do zoom, when map becomes invisible.

 

Some suggestion?

 

Thanks in advance.

Outcomes