ddavis_talltimbers

Unable to restore datastore on standby server

Discussion created by ddavis_talltimbers on May 22, 2020

I am trying to perform a restore of our primary datastore onto our secondary server in hopes that it will allow our webgisdr restore process to complete without issues.

 

I have not been able to restore a datastore backup made from our primary server to a standby server.  I have tried accessing the primary backup from a file share and after copying it to a local directory on the standby server.  

 

Using a UNC path (\\server\share\dsbackups) with the --source-loc parameter fails with a 'Backup location does not exist.' error.   This same path (\\server\share\dsbackups) is registered as an alternate backup location on the primary server.

 

Copying the primary datastore backup to the local default backup location on the secondary server.  Caused a different error: 'Failed to create relational data store database '{0}'.'

 

Does the backup location have to be registered and/or made "isDefault" with the standby server before a restore can occur?  Does the datastore backup location have to be the default software install location (in our case Z:\arcgisdatastore\backup\relational)?  

 

The backup of the primary datastore was created using an alternate location that was registered with configuredatastore.  Does the backup need to be made at the default location on the primary server and then be copied to the same location on the standby server?

 

Thanks in advance for any help.  Best, Dixie.

Outcomes