AnsweredAssumed Answered

Can't join subset of points to polygons

Question asked by rannechino_PIRE on Apr 29, 2020
Latest reply on May 4, 2020 by smilesesriaustralia-com-au-esridist

I'm having a problem with a spatial join that I've never run into before (using ArcGIS Desktop 10.7.1).. I'm trying to join about 180,000 points to census tract polygons. The join works for about 140,000 of these points. When I look at the remaining 40,000 points, many of them appear to be on the border lines of tracts.

 

I tried re-projecting the points and repairing the geometry of the census tract polygons, but got the same result.

 

Then I tried adding a buffer to the tract polygons just to see what would happen. The last buffer I tried was pretty large, and I can see that many of the 40,000 points clearly fall completely within the buffered polygons (not on the edges). But when I run a spatial join between those points and the buffered polygons, nothing joins up.

 

I'm at a loss on what the problem could be. Any thoughts would be much appreciated.

Outcomes