AnsweredAssumed Answered

locationWhenInUseDescription not updating in App Store

Question asked by acurtis@carthage.edu on Apr 28, 2020
Latest reply on Apr 29, 2020 by ESoekianto-esristaff

I am trying to publish an application through App Studio for ArcGIS, and have been in trouble updating the location permissions string for the uploading process to Apple. They were unable to accept the default string that is used through App Studio as: "your app still requests the user’s consent to access their location but does not clarify the use of the location in the applicable purpose string".

 

 

I have tried to change the description key more than once within the appinfo.json file on Qt Creator, saving it, followed by updating/uploading the new build before making the new binary. I continue to get the same screenshot back from Apple with the default App Studio string after resubmitting twice. I was looking for advice on how to get this to update correctly. I have changed the icon in the past without a problem within the same appinfo.json file, but for some reason, this specific string won't update. I can't open the binary file within Xcode to check the Info.plist file to debug or through App Studio Player since it does not use the individual app's location description message, so I am looking for any debugging suggestions as well.

 

Here is how my current description key looks within appinfo.json:

 

Any help you can provide me would be helpful. Thanks. (Sorry this was just reuploaded, it was originally sent through the wrong account).

Outcomes