AnsweredAssumed Answered

Union results in new polygons

Question asked by philip.white_ucboulder on Apr 27, 2020
Latest reply on Apr 27, 2020 by Dan_Patterson

Hello,

 

I'm consulting a student who is running into a problem with a Union operation, and I've been struggling to figure out why the results look as they do.

 

My student has about 100 vector layers they're attempting to Union. The output file is a lot of strange new features that were not present in the any of the original input layers. I can't figure out why this is happening. 

 

Troubleshooting this, I started running a Union on just 2 layers at a time. Discovered this was happenning here as well.

 

For example, here are the two input layers displayed on top of one another (participant2, participant3):

 

I run the Union on these two, and I would expect the shapes of all the features/new features to appear identical to the input layers, but they do not. See the new Union2_3 layer in red, and note the red ellipse at center that is now a different geometry than the input:

 

Why is this happening?

 

I ran the Check Geometry tool to see if there was something wrong with the input data, but it doesn't detect any geometry errors.

 

Why would new features get created? Or why would the geometry of the original not be preserved in the new output Union?

 

FYI: this operation worked as expected in QGIS.

 

Thanks,

Phil

Outcomes