AnsweredAssumed Answered

Address Locator taking forever to complete in ArcGIS Pro/ArcMap

Question asked by david.bondy.metrolinx on Apr 16, 2020
Latest reply on Apr 19, 2020 by sbritt-esristaff

I'm trying to build a address locator in ArcGIS Pro 2.3.3 and I've been experiencing issues with the length of time it takes to complete the address locator. I've built one using the same source data and it took about 20 minutes to complete. When I've run it with the adjusted data, it still hasn't completed after 21 hours.

 

 I needed to make adjustments to the dataset to standardize some of the values between the municipalities so I built a FME model to handle the data transformations. The source data was the same for both which is open data collected from 21 different municipalities, totaling ~2,800,000 records for the original and new, standardized datasets. The locator syle is 'US Address - Single House Subaddress' and has 1 primary table, 1 alias table, and 1 city alias table.

 

When I run the Create Address Locator tool against the standardized data, it continues increasing the number of cached records without moving past that stage. When i  stopped it after 21 hours, it was at ~13,000,000,000 records cached.

 

Does anyone have any insight into what may be contributing to this?

 

EDIT: I ended up finding the source of the problem. My Alternate City Name table had a bunch of duplicates in it which I'm assuming was causing the address locator tool to generate A LOT of additional relationships that weren't necessary, I refined the tables based on unique values and the address locator is now being created is a reasonable time frame. 

 

Thanks to those of you who provided feedback.

Outcomes