AnsweredAssumed Answered

Get Error 001487: Failed to update the published service with the server-side data location, when publishing Utility Network data

Question asked by joelma923 on Apr 6, 2020
Latest reply on Jun 1, 2020 by naveen13

I have tried many different things but still getting this error whenever I publish some utility network data.  I was just trying out the ESRI sample Sewer Utility Network data (Naperville), followed the instructions to apply asset package, registered as branch versioned, enabled network topology, then tried to publish the map with utility network data from ArcGIS Pro, then got that error.  My environment:

 

SQL Server Express 2019

ArcGIS Enterprise 10.7.1 (federated server with portal)

ArcGIS Pro 2.5

 

Weird thing is, I could publish another feature class from the same database just fine!  I even tried publishing the Service Territory feature class within the utility network feature dataset and that was ok too!  So ArcGIS Server can access that database fine, it somehow just doesn't like the utility network data.

 

The database is registered with ArcGIS Server, and seeing that I'm getting this error, I also created a data store item in Portal based on this: Create a data store item for an existing registered data store—Portal for ArcGIS (10.7 and 10.7.1) | Documentation for…  BUT, that did not help at all.

 

I also tried arcpy, created an SD file and attempted to publish it directly in ArcGIS Server Manager - and got the same error!

Error 001487

 

Feels like this error will haunt me forever... I'm all out of ideas now, any help is much much appreciated!

Outcomes