AnsweredAssumed Answered

Arcgis runtime iOS: download of geodatabase stucks

Question asked by deriuv on Apr 6, 2020

Hi,

I'm developing an iOS app with runtime api 10.2.7 and I have an issue while downloading an offline geodatabase.

 

When the generation of the ".geodabase" file has completed on the arcgis server, sometimes I see that my client hangs up in downloading the file from the geoprocessing output folder. 

 

I tried to retrieve the file url by searching the name of the generated geodatabase on my arcgis server (10.7.1) cluster and tried to download the file from my laptop and from safari on the ios Device.

 

The result is that, while the download process is quite fast from my laptop, when I try to download the geodatabase from Safari it sometimes hangs up and it seems to be "stuck". If I pause the download and then restart it, the download process continues for some seconds and then hangs up again. After some restart/stop of the download in Safari, it completes.

 

A similar behavior can be seen from the app I have developed, since the download starts quickly and then hangs up for some minutes, then it restarts, and so on.

 

Did anyone experienced the same issue?

 

Thank you all.

Outcomes