AnsweredAssumed Answered

ArcGIS 10.6 tools working on my computer but not another one

Question asked by Zenchi on Apr 5, 2020
Latest reply on Apr 5, 2020 by Zenchi

Good morning,

 

I'm new in this community forum (And also in ArcGIS, been only a few weeks I started), so if I need to add more informations, ask me. The problem doesn't come from my PC so it can take some times because I need to contact the chief of the project.


So my problem is:
I made 2 python scripts for an add-in and toolbox but none of them work on his pc. I tried to search on internet about how to solve this issue.

 

The first script is only calling Contour and fails directly (Errors: 999999 and 010067) and the second one is calling multiple functions of ArcGIS:
The second script is failing on the function called Union.

 

I asked him to:

- check if all the extensions are enabled -> it is

- check if it was due to him using a GeoDatabase or not, he then tried without the GeoDatabase, it didn't work.
- he tried Contour from the application ArcMap but it still works with the same file.

 

The zip file contains the whole code for the add-in and toolbox.

 

Thank you for your time.

error999999 arcgis10.6 error010067 arcgis toolboxpython addin

Outcomes