AnsweredAssumed Answered

Quick Report template not able to use Multipoint Feature Service

Question asked by masterraster on Mar 17, 2020
Latest reply on Mar 24, 2020 by masterraster

We are using AppStudio for ArcGIS Desktop version 4.2.80

 

The AppStudio is configured with ArcGIS Portal 10.6

 

The features service is sync and editor tracking enabled, following is the JSON of the service: 

{  "currentVersion": 10.6,  "id": 0,  "name": "GurDevOfflineSyncEditorTracking",  "parentLayerId": -1,  "defaultVisibility": true,  "minScale": 0,  "maxScale": 0,  "type": "Feature Layer",  "geometryType": "esriGeometryMultipoint",  "description": "",  "copyrightText": "",  "editFieldsInfo": {   "creationDateField": "created_date",   "creatorField": "created_user",   "editDateField": "last_edited_date",   "editorField": "last_edited_user"  },  "ownershipBasedAccessControlForFeatures": null,  "syncCanReturnChanges": true,  "relationships": [],  "isDataVersioned": false,  "supportsRollbackOnFailureParameter": true,  "archivingInfo": {   "supportsQueryWithHistoricMoment": true,   "startArchivingMoment": 1584096599000  },  "supportsStatistics": true,  "supportsAdvancedQueries": true,  "supportsValidateSQL": true,  "supportsCalculate": false,  "advancedQueryCapabilities": {   "supportsPagination": true,   "supportsTrueCurve": true,   "supportsQueryWithDistance": true,   "supportsReturningQueryExtent": true,   "supportsStatistics": true,   "supportsOrderBy": true,   "supportsDistinct": true,   "supportsSqlExpression": true  },  "extent": {   "xmin": "NaN",   "ymin": "NaN",   "xmax": "NaN",   "ymax": "NaN",   "spatialReference": {    "wkid": 102100,    "latestWkid": 3857   }  },  "drawingInfo": {   "renderer": {    "type": "simple",    "symbol": {     "type": "esriSMS",     "style": "esriSMSCircle",     "color": [      51,      0,      133,      255     ],     "size": 4,     "angle": 0,     "xoffset": 0,     "yoffset": 0,     "outline": {      "color": [       0,       0,       0,       255      ],      "width": 1     }    },    "label": "",    "description": ""   },   "transparency": 0,   "labelingInfo": null  },  "hasM": false,  "hasZ": false,  "allowGeometryUpdates": true,  "allowTrueCurvesUpdates": false,  "onlyAllowTrueCurveUpdatesByTrueCurveClients": false,  "hasAttachments": false,  "supportsApplyEditsWithGlobalIds": true,  "htmlPopupType": "esriServerHTMLPopupTypeAsHTMLText",  "objectIdField": "OBJECTID",  "globalIdField": "GlobalID",  "displayField": "Data",  "typeIdField": "",  "subtypeField": "",  "fields": [   {    "name": "Data",    "type": "esriFieldTypeString",    "alias": "Data",    "domain": null,    "editable": true,    "nullable": true,    "length": 50   },   {    "name": "created_user",    "type": "esriFieldTypeString",    "alias": "created_user",    "domain": null,    "editable": false,    "nullable": true,    "length": 255   },   {    "name": "created_date",    "type": "esriFieldTypeDate",    "alias": "created_date",    "domain": null,    "editable": false,    "nullable": true,    "length": 8   },   {    "name": "last_edited_user",    "type": "esriFieldTypeString",    "alias": "last_edited_user",    "domain": null,    "editable": false,    "nullable": true,    "length": 255   },   {    "name": "last_edited_date",    "type": "esriFieldTypeDate",    "alias": "last_edited_date",    "domain": null,    "editable": false,    "nullable": true,    "length": 8   },   {    "name": "GlobalID",    "type": "esriFieldTypeGlobalID",    "alias": "GlobalID",    "domain": null,    "editable": false,    "nullable": false,    "length": 38   },   {    "name": "OBJECTID",    "type": "esriFieldTypeOID",    "alias": "OBJECTID",    "domain": null,    "editable": false,    "nullable": false   }  ],  "indexes": [   {    "name": "UUID_118",    "fields": "GlobalID",    "isAscending": true,    "isUnique": true,    "description": ""   },   {    "name": "gdb_ct3_118",    "fields": "OBJECTID",    "isAscending": true,    "isUnique": false,    "description": ""   },   {    "name": "S70_idx",    "fields": "SHAPE",    "isAscending": true,    "isUnique": true,    "description": ""   }  ],  "dateFieldsTimeReference": {   "timeZone": "UTC",   "respectsDaylightSaving": false  },  "types": [],  "templates": [   {    "name": "GurDevOfflineSyncEditorTracking",    "description": "",    "prototype": {     "attributes": {"Data": null}    },    "drawingTool": "esriFeatureEditToolPoint"   }  ],  "maxRecordCount": 1000,  "supportedQueryFormats": "JSON, AMF, geoJSON",  "capabilities": "Create,Delete,Query,Sync,Update,Uploads,Editing",  "useStandardizedQueries": true }

When I run the Quick Report application with feature service defined above I get the following error: 

 

 

Any suggestions will be appreciated.

Outcomes