AnsweredAssumed Answered

How to update extremely old DLL to 100.7 sdk

Question asked by TerryCoe on Feb 24, 2020
Latest reply on May 19, 2020 by MBranscomb-esristaff

Recently, my team has inherited an older application and have been tasked with updating the packages that it has. i have three ESRI.ArcGIS.Client dll's that were downloaded into the Visual Studio 2008 solution when the app was created:

ESRI.ArcGIS.Client (version 3.0.0.318)

ESRI.ArcGIS.Client.Toolkit (version 3.0.0.318)

ESRI.ArcGIS.Client.Local (version 1.0.0.3057)

I cannot find documentation anywhere for these versions, and when I use the Nuget Package Manager to download the 100.7, and remove the previous version, i get somewhere around 775 errors, mostly for classes that don't exist in the new versions. 

Is there anyone that may have the above mentioned versions' documentation stashed anywhere so I can definitively tell what the classes and methods I have in my application are and/or how i could define them enough to map them to objects, classes, or methods in 100.7?  

Outcomes