AnsweredAssumed Answered

WFS GetFeature: NamespaceUri mixup

Question asked by krdyke on Dec 13, 2019
Latest reply on Mar 13, 2020 by PKlingman-esristaff

Hi,

 

I'm attempting to consume features from a hosted WFS service on ArcGIS Online. I'm using the same layer used in the WFS example for the JavaScript API (WFS Layer | ArcGIS API for JavaScript 3.30 ).

 

The ArcGIS JavaScript example works fine, but fails when I attempt to read the layer using Leaflet-WFST. Looking closer at the response to the GetFeature request, note the value for xmlns:JapanPrefectures2018 in line 5.

 

<?xml version="1.0" encoding="utf-8" ?>

<wfs:FeatureCollection xmlns:xs="http://www.w3.org/2001/XMLSchema"
xmlns:wfs="http://www.opengis.net/wfs" xmlns:gml="http://www.opengis.net/gml"
xmlns:JapanPrefectures2018="http://dservices.arcgis.com/arcgis/services/V6ZHFr6zdgNZuVG0/JapanPrefectures2018/WFSServer"
xmlns:xlink="http://www.w3.org/1999/xlink" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
timeStamp="2019-12-13T20:54:48Z"
numberOfFeatures="unknown"
xsi:schemaLocation="http://www.opengis.net/wfs http://schemas.opengis.net/wfs/1.1.0/wfs.xsd
http://www.opengis.net/gml
http://schemas.opengis.net/gml/3.1.1/base/gml.xsd
http://dservices.arcgis.com/arcgis/services/V6ZHFr6zdgNZuVG0/JapanPrefectures2018/WFSServer
https://dservices.arcgis.com/V6ZHFr6zdgNZuVG0/arcgis/services/V6ZHFr6zdgNZuVG0/JapanPrefectures2018/MapServer/WFSServer?service=wfs%26version=1.1.0%26request=DescribeFeatureType"
>

The value reads http://dservices.arcgis.com/arcgis/services/V6ZHFr6zdgNZuVG0/JapanPrefectures2018/WFSServer, which is not correct. The value needs to be http://dservices.arcgis.com/V6ZHFr6zdgNZuVG0/arcgis/services/JapanPrefectures2018/WFSServer.

 

I attempted publishing a WFS Layer using a hosted feature layer and it produces the same error. I also tried publishing a WFS service from ArcGIS Pro, which works perfectly, I'm guessing because the Namespace is set as an option when publishing via Pro.

 

Any ideas? Is this a bug? Something I've missed? Something else?

Outcomes