AnsweredAssumed Answered

Import arcpy (Py2.7.16 x32Arc107) or arcgis (Py3.6.2-x64Pro)

Question asked by mravichandran on Nov 20, 2019
Latest reply on Nov 21, 2019 by mravichandran

dear Readers,

 

thanks for taking the time to read through my question.  I am trying to start with a sample code with python script.

 

Question:

  1. Which python interpreter should be used 2.7.x (32 bit) that came with ArcGIS 10.x (6 or higher) or Py 2.7 (x64)?
    1. will import arcpy work on that? 
    2. I am unable to import ArcGIS module or use 'from ArcGIS.gis import GIS'
  2. if I make ArcGIS module work by changing it to 3.6.2 (conda) version then my arcPy goes away.

 

I have both ArcGIS pro and ArcGIS desktop advanced suite running on my workstation and virtual machine.  yes, I am beginner in Python but many years experience with ESRI objects and 'ArcObjects'.

 

any documentation or guidance would be great.

 

thanks for your help.

 

regards

ravi kaushika

Outcomes