AnsweredAssumed Answered

Unable to access Vector Tile Layers in ArcGIS Pro from ArcGIS Online

Question asked by rohit.mendadhala_tfsgis on Nov 19, 2019
Latest reply on Nov 19, 2019 by rohit.mendadhala_tfsgis

I created a custom base map to just hide the labels of the Hybrid Reference Layer in the Vector Tile Style Editor Portal and then saved it to AGOL. I shared the vector tile layer with a group for which I am the group owner/manager. Now when I log in to ArcGIS Pro and try to import the layer from the catalog, it shows a broken link like below. 

When I navigate to the data source URL, it says that I do not have permission to access this resource.

I also tried downloading the JSON style( root.json) and tried importing it in ArcGIS Pro. But it didn't even show that as an option to do. Is there something I am missing here?

 

One weird thing, I observed is when I share the customized hybrid reference layer openly (Everyone/Public) then I am able to access the layer without any issues in ArcGIS Pro? Not sure what is the reason though.

Appreciate it if anyone could throw some light on this!!.. Thank you.

Outcomes