AnsweredAssumed Answered

Info Summary Widget

Question asked by Jeremy.Wolff_qgsp on Nov 6, 2019

Hi, 

 

I have made an app which uses the Info Summary Widget to summarise the features displayed on the current extent of the map. 

 

The features are species sightings which are coming from multiple layers (flora, fauna, angiosperms, all sightings and so on). 

 

The Info Summary Widget worked very well for me when the MXD that I had published a few months ago only had one or two layers (all sightings). At that point I used the Info Summary Widget to summarise those feature by 'Family'.

 

Now that I have more layers which separates fauna from flora and other classes and groups, I use this widget so summarise tow layers; fauna and flora grouped by 'flora group' and 'class'. This was working very well until I made a few edits to the map (renamed a layer, enabled pop up window, added labels to another layer) Since then, Every time that I use the Info Summary Widget, for some weird reason all the layers get turned on by themselves, even those turned off in the layer tool. 

 

Now I have spent hours trying to understand where the problem was coming from. And started narrowing down where the problem started. So I have removed my web service from the map and re added the same layer from web and reset the Info Summary widget to point to flora and flora. Worked great.

 

Then, I have started to re edit the map and re enable pop-up window. Worked great when I used the Info summary tool.

 

Then I went back to the map and added labels to a layer. And for some weird reason, when I used the Info Summary tool in the app, all the layers turn on by themselves again. 

 

I have removed and re added and my layers dozen of times, tried every edit and solution I could think of. Everything works I add labels to any layer in the map and that create a bug where all the layers will turn on when I use the Info Summary Widget. 

 

If you know how I could fix this that would be very helpful!

 

Jeremy 

 

Here is a few photos of what I am doing (basically three steps: 1 setting up he Info Summary Widget and making sure is works, which is does. 2. Making edits to the map by adding label. 3. re-checking how the app works and seeing that the Info Summary Widget now makes all layers appear for no reason.

 

The URL I have been using and which worked great until now:

 

http://sirgisdev/arcgis/rest/services/WildNet2/MapServer

 

https://uat-gisservices.information.qld.gov.au/arcgis/rest/services/EncompassApps/WildNet/MapServer 

 

 

Jeremy Wolff

Biodiversity Information Officer (WildNet Program) - Spatial and Wildlife Unit

Science Information Services – Digital and Information Services - Science & Technology Division

Department of Environment and Science

__________________________________________________________________

P 07 3170 5425 E Jeremy.Wolff@des.qld.gov.au

Ecosciences Precinct G.C.W. 41 Boggo Road Dutton Park QLD 4102 or GPO Box 2454 Brisbane QLD 4001

Customers first | Ideas into action | Unleash potential | Be courageous | Empower people

Outcomes