AnsweredAssumed Answered

Register web adaptor to portal

Question asked by axioma.admin on Oct 16, 2019

Hey All, 

I have one server which hosts the ArcGIS server the portal and 2 web adaptors

I have successfully registered one of the web adaptors with the server but I am getting error while trying to register the second web adaptor with the portal (the portal is installed correctly and working)

ESRI Arc + portal + web adaptors version 10.7.1

Windows 10 Etn 64bit (32GB Ram) + IIS + RSA SSL Certificate 

 

when I try register it from the web - I can see the following error in event viewer: 

Event code: 3005 

Event message: An unhandled exception has occurred. 

Event time: 10/16/2019 1:29:02 PM 

Event time (UTC): 10/16/2019 10:29:02 AM 

Event ID: c5f92c7191744d9da5b015879f65d9c4 

Event sequence: 21 

Event occurrence: 1 

Event detail code: 0 

 

Application information: 

    Application domain: /LM/W3SVC/1/ROOT/portal-1-132156890571466549 

    Trust level: Full 

    Application Virtual Path: /portal 

    Application Path: C:\inetpub\wwwroot\portal\ 

    Machine name: GIS 

 

Process information: 

    Process ID: 17096 

    Process name: w3wp.exe 

    Account name: IIS APPPOOL\ArcGISWebAdaptorAppPool v4.0 

 

Exception information: 

    Exception type: NullReferenceException 

    Exception message: Object reference not set to an instance of an object.

   at ESRI.ArcGIS.WebAdaptor.WebAdaptor.()

   at ESRI.ArcGIS.WebAdaptor.WebAdaptor.Page_Load(Object sender, EventArgs e)

   at System.Web.UI.Control.OnLoad(EventArgs e)

   at System.Web.UI.Control.LoadRecursive()

   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

 

 

 

Request information: 

    Request URL: https://gis.xxx.com:443/portal/webadaptor/WebAdaptor.aspx 

    Request path: /portal/webadaptor/WebAdaptor.aspx 

    User host address: fe80::897c:ba2:e15:c0cIIS APPPOOL\ArcGISWebAdaptorAppPool v4.0 

    User:  

    Is authenticated: False 

    Authentication Type:  

    Thread account name: IIS APPPOOL\ArcGISWebAdaptorAppPool v4.0 

 

Thread information: 

    Thread ID: 50 

    Thread account name: IIS APPPOOL\ArcGISWebAdaptorAppPool v4.0 

    Is impersonating: False 

    Stack trace:    at ESRI.ArcGIS.WebAdaptor.WebAdaptor.()

   at ESRI.ArcGIS.WebAdaptor.WebAdaptor.Page_Load(Object sender, EventArgs e)

   at System.Web.UI.Control.OnLoad(EventArgs e)

   at System.Web.UI.Control.LoadRecursive()

   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

 

 

Custom event details: 

 

 

 

When I trying to register the web adaptor from command line I am getting the error:

Configuring Web adaptor...

Successfully Registered.

 

but it is not registered

 

 

Please help

 

Roy

Outcomes