AnsweredAssumed Answered

Survey123 3.6.155 not auto-calculating inside relevant group

Question asked by jakethepainter on Oct 10, 2019
Latest reply on Oct 13, 2019 by Philip.Wilson-esristaff

I have a survey that works as expected in the earlier version of Survey123 but in 3.6.155 (iOS) I get unexpected behavior.

 

I have a group which has relevancy set.  Even when the group is relevant within the form, some of the autocalculations are not occurring. If I move them outside the group, they perform as expected.

 

The reason I have the entire group of questions wrappered in a relevant group is so that the form cannot be opened directly from Survey123.  The questions in the form only become relevant when the form is being opened from a custom url passed from Collector which passes a feature GUID.

 

I'm particularly surprised that the row of type username  doesn't calculate.  It's not dependent on anything being passed into the form from the URL.

 

I've attached the version of the form that fails in the new version of S123 but worked as intended in the old version and then a version of the form which works in the new version. 

 

I'm lucky in this case that the calculations are ones that are hidden from the user so I don't mind where they are located in the form, but I have other more complex forms that are not that way. 

 

I saw this discussion about calculations within non-relevant groups but I'm not sure if the behavior I'm experiencing is related or not, since my group is relevant.

https://community.esri.com/thread/241140-calculation-question 

Philip Wilson

Outcomes