AnsweredAssumed Answered

Survey Stuck on Mobile Device

Question asked by grahamstobieSPEN on Oct 4, 2019
Latest reply on Oct 9, 2019 by grahamstobieSPEN

Hello

 

I have an issue with a survey on an iPad that will not send. I've tried a few of the suggested fixes but no luck so far - any other suggestions appreciated.

 

The survey itself is set up with repeats and select-multiples, and has the Inbox enabled - I think these have all been a potential source of problems in the past but the survey has been created/collected in a recent version of Survey123 so should be fine. Surveys collected before and after this one, using the same version of the survey form and following the same process, have all worked without a hitch.

 

The survey data has been collected by two different people, so the records are sitting on two devices (they shared the survey using the Inbox). The same issue is affecting the data on both devices. Initially the 'parent' record uploaded fine, but none of the 'child' repeat records could be sent. I've since deleted the parent record from the Feature Class in ArcGIS Online and tried sending again, but now nothing is being sent.

 

I've been able to copy the sqlite database to my desktop and open it on the desktop version of the app, but get the same error message when trying to send it (first image below). I've also tried opening the database using DB Browser for SQlite and checked the filepath but all looked OK (second image).

 

I've seen an option to extract the data to a CSV but it looks like it needs GIitHub skills/access and I have neither!

 

Is there anything obvious I'm doing wrong/missing, or anything else I can try?

 

Thanks for your help!

Outcomes