AnsweredAssumed Answered

Feature not displaying completely

Question asked by mdiskin_usfs on Sep 20, 2019

I have a couple feature layers hosted in AGOL that are not displaying completely.  They are linear features, one with ~400 lines.  They will not display completely until I zoom in real far.  Interestingly, they will fully display if I "enable editing."  What's going on?  I've tried every troubleshoot I could find on this forum...repair geometry, rebuild spatial indexes...and nothing works.  Surely 400 lines is not too much to display?

 

I've tried smaller subsets of one of the feature layers, and it will fully display with up to ~200 features.  I am not convinced that the number of lines is the sole reason for the layers to not display fully.  Are there any other things that might be causing this?  Any known ways to fix it?  Besides repair geometry or rebuild spatial indexes?

 

Related, in one instance, I had a very small subset of 25 of these lines.  That displayed.  Once I edited three of the lines in ArcGIS Pro and shared on AGOL again, this layer did not display either.  Any insight as to what's going on?

 

I am suspicious it might be due to multipart features or other GIS gremlins hiding in this data.  File attached if anyone's interested.

 

Thanks for the help!

 

Matt

 

Update: exploding multipart features improved performance and allowed a subset of ~400 features to display (attached).  The full data set, ~15,000 lines still will not fully display.  That seems more reasonable, but I'm still not convinced that there's some other cause.  See image from AGOL below.  Most of the lines continue into the empty space in the western half of the image.

 

Attachments

Outcomes