AnsweredAssumed Answered

How to ensure data is copied to Image Server from Mosaic Dataset in Pro?

Question asked by ewiggans_CC on Sep 6, 2019

We've recent started to make the jump to managing our stand-alone ArcGIS Server in Pro from previously using just ArcMap. I've been trying to figure out how to publish a mosaic dataset of land cover data to be an image server and allow it to be configured to include pop ups showing a data value (and/or text field showing the class) if you click on it. I'm publishing with an administrator connection, and referencing registered data. I am also including a raster function for symbology in my upload; it should be 8-bit discrete, unique values. We have an existing layer we published out of ArcMap some time ago that's actually now on the Living Atlas (below) where you can see it happily shows pop ups of the land cover class - as far as I can tell, same configurations, also a Image Server, from a mosaic dataset, discrete land cover data...

 

No matter what I've tried, in publishing as an image service, I continue to get errors when I either look at the attribute table in an AGOL map and I can't configure pop ups - all the fields show up, but it says "no information available". Further confounding, when I pull the data from the server back into a fresh ArcPro document, I'm able to see raster values and the mosaic dataset's attribute table just fine. 

 

Anyone have any thoughts on why I'm unable to get this to cooperate in ArcGIS Online published on our server?

 

https://www.arcgis.com/home/item.html?id=d64b1ee826d64c4b8267d82aa954e190

Outcomes