AnsweredAssumed Answered

Parcel Fabric LGIM - "The spatial index grid size is invalid" during adjust

Question asked by dbollinger on Aug 21, 2019



ArcMap 10.6.1, latest LGIM.


I have a portion of California's CadNSDI PLSS in a local file geodatabase (current ver), and loaded into a parcel fabric.  Everything throughout uses the exact same coordinate systems (XY=EPSG2227, Z=EPSG5703) specifically including the ParcelEditing fds and the editing map's data frame.   Domain/resolution/tolerance are all the high-resolution defaults (~=0.00032808333333... US Survey Feet)


Whenever I attempt an adjustment in the fabric, at the point where it says "Writing adjustment vectors" the following error occurs:

"The spatial index grid size is invalid [ParcelFabric_Adjustments]"


I'm aware of this:  Common errors that may occur during editing—Help | ArcGIS Desktop 

but it's not (apparently?) possible to drop/recreate/reconfig the spatial index on this "hidden" feature class "ParcelFabric_Adjustments" internal to the fabric.


I have attempted to recreate indexes on the points/lines/polys, but it makes no difference.  Also tried recalculating the XY extent of each point/line/poly, again no effect.  Tried recalc extent THEN recreate index, again no effect.


Then I created a personal geodatabase and bulk copied the entire contents of the fgdb into the pgdb.  Guess what?  That same adjustment succeeded!  So what's up fgdb?


Problem is, a pgdb really isn't workable for this project.  Plan was:  eventually, after the initial local adjustment edits were performed, it'd reside in MSSQL.  I don't want it in MSSQL prior to that work for performance reasons (maybe it's just our setup, but large-scale fabric adjustments suck in MSSQL, so we were hoping to get the "reference" layers (the PLSS) in good shape via local gdb before shoving them in with several hundred thousand tax and ownership parcels)


So, finally a question:  Any way I can get the fabric to work from a file geodatabase?