AnsweredAssumed Answered

My related tables just stopped working in Collector after weeks of success.

Question asked by mbs92_yalemaps on Jul 20, 2019
Latest reply on Jul 25, 2019 by KDonia-esristaff

I had a nice set of relationships working in the new Collector from this project's beginning.     I did a bunch of work today online before noticing that Collector stopped seeing the records in my relation.  Of note:

 

  1.  I renamed the hosted feature layer. (ugh)
    1. new maps based on the hosted layer don't work in Collector either
  2. I added domain values to the service definitions for some fields via REST,
    1. (but that had worked a number of times before)
  3. I created a number of hosted feature layer views for the layer, so I could set different editing levels.
  4. I created a DateDiff expression and a simple string output expression in another layer.
    1. I deleted those just in case
  5. I changed group share access, but I own the assets and am in the groups that have permission.
  6. I tried without Sync in the hosted feature layer views and then with Sync.

 

The web maps all work as expected, but now I cannot access my related tables in Collector.   It sees the table name and I can go to that screen, but no records are shown, and will not allow a new record to be added.

 

I did not restrict permissions in this parent hosted layer, though I did change its name.   

 

The web maps work fine for my account, and I installed the Classic Collector and it can see the records as well.    

 

What did I do to trash the new Collector?   I need it back, by Monday of course.   Thanks in advance for any clues out there.

Outcomes