AnsweredAssumed Answered

Project Referenced DLL not Extracting from .esriAddinX

Question asked by mattrjackson on Jul 17, 2019
Latest reply on Jul 18, 2019 by mattrjackson

Good Morning,

 

I just upgraded to 2.4 today, and ran across an issue that I had solved in the past by manually copying a dll into the assemblycache\guid directory, but I'm wondering if there is a better solution? I am using the MathNet.Numerics library in my project, in addition to a number of other libraries. All of the other referenced libraries in the project seem to copy just fine. Below is an example of what I'm seeing when I look in the AssemblyCache\guid subdirectory. As you can see, it copies the xml file describing the assembly, but does not copy the assembly itself.

 

 

Interestingly enough, if I dig into the .esriAddinX archive generated by visual studio, MathNet.Numerics.dll appears to be present, and if I extract it manually using 7zip, the dll is extracted as expected. I tried deleting the assemblycache\guid directory, but when it repopulates, the same file is missing. Any ideas?

 

Thanks,

 

Matt

Outcomes