AnsweredAssumed Answered

Is there any way to stop ArcGIS Pro from assuming a Revit file units are meters when in fact they are decimal feet?

Question asked by aviris on Jul 11, 2019
Latest reply on Jul 17, 2019 by DAlvarez-esristaff

My scenes and maps are state plane US Feet. My Revit (2019) models are US Feet. When I pull them into ArcGIS Pro the models are 1/3 size, and 1/3 of the way from the origin to where they are supposed to go. 

 

Finally discovered that if I change my Revit model units to fractional feet and inches then ArcGIS Pro renders them full size and in the correct location.* I can't find a setting anyplace in ArcGIS Pro to change this behavior. As the GIS guy, I don't have ability to change the units.

 

Bonus question: 
* Same State Plane US Feet scene, even when Revit layers are recognized as feet and are the correct scale and location, every layer still defaults to "meters" as the elevation unit, so I've got 6 foot tall drinking fountains and 32+ foot stories. It is easily changed in the Properties|Elevation, but if anyone know how to tell ArcGIS Pro to use the same units for Z as it is using X & Y that would be great (particularly because it is every layer, even those coming from the same file that I've already changed Elevation units to US Feet.

Outcomes