AnsweredAssumed Answered

Election Outreach solution - symbology in the feature service in Pro not showing in the web map

Question asked by jhodny@Newark.de.us_CityOfNewarkDE on Jul 2, 2019
Latest reply on Jul 16, 2019 by jhodny@Newark.de.us_CityOfNewarkDE

I am using ArcGIS Pro 2.4.  I have deployed the new Election Outreach Solution in our ArcGIS Online organization portal using the Solution Deployment tool through Pro.  I have added our elected representatives data into the ElectionGeography feature service....Electoral Districts service feature class (2) in Pro (using the Load Data task in the Solution Deployment tool), and tweaked the symbology of the Electoral Districts service class (2) in Pro.  I am symbolizing on the 'Elected Office' field.  When I open the solution's web map (My Elected Representative) in the AGOL map viewer, the symbology for the Electoral District's service layers is not shown.  The Table of Contents shows the various elected representatives in the list, but the legend is completely blank.  When I open each of the attribute tables in the viewer, the tables are populated with the correct data.  I thought the symbology used in the service feature class in Pro (line and polygons) would be passed to the ElectionGeography_public View used in the web map and seen in the viewer?  Do I have to bring the View into Pro, symbolize this layer too, or symbolize the View in AGOL?  It sure would be nice to do the work in Pro, and have it pass through to the View, et al.  Obviously I am not understanding the View concept and/or how the Esri solutions work in general.  Thanks in advance.

Outcomes