AnsweredAssumed Answered

Adding a uniquevaluerenderer removes Categories option from properties.

Question asked by dmpetersen on Jun 26, 2019

Shows missing Categories option

 

I'm adding a new layer to the TOC based on a line feature class in the currently connected database. I included a new UniqueValueRenderer with two fields defined with values added with symbology. This works and changes both the TOC and the lines being displayed on the map. However when I go into the new layer's properties the "Categories" option is missing. On a 10.2.1 implementation clicking the layer's checkbox off and on will cause some kind of reset and the properties and the Categories option becomes visible. However, on a 10.6.1 implantation this does not work. In either version just clicking apply or ok in the properties window resets the layer to Features/Single symbol. I have tried many things, but nothing has worked yet. Nothing I've refreshed in code has helped. Somehow I'm just not getting the layer and its properties sync'd. I'm wondering if anyone else has run into this behavior with the UniqueValueRenderer?

Outcomes