AnsweredAssumed Answered

Could Make Error: No signing certificae "iOS Development" found

Question asked by heathjr on Jun 23, 2019
Latest reply on Jun 23, 2019 by heathjr

Have an app developed using AppStudio for ArcGIS 3.1.134. Was able to successfully generate an ios build using cloud make at end of last month. Tried to generate a build today but this failed due to an expired developer certificate. I went through the usual process to update STBB with a new certificate, but the cloud build is still failing but this time with a different error (in attached screenshot).

 

I can't work out if this is an issue with how I've regenerated the cert or updated the STBB config, but this is a process I've followed before without issue. I'm not receiving any build notifications from cloud make so don't have any further details to go on.

 

In case this is an issue with how I regenerated my certificate, here's the process I followed (PC is running Windows 10 with OpenSSL 1.1.0h 27 Mar 2018):

  1. Run OpenSSL from an elevated command prompt
  2. Generated CSR: 
    req -out csr.csr -new -newkey rsa:2048 -nodes -keyout pvt.key
  3. Entered info and challenge password as prompted.
  4. Successfully created an IOS developer certificate from the CSR. Downloaded to PC. Installed cert.
  5. Updated provisioning profile to use new certificate. Downloaded to PC.
  6. Generate PEM:
    x509 -inform der -in ios_dev.cer -out ios_dev.pem
  7. Generated P12:
    pkcs12 -export -out MyApp_Dev.p12 -inkey pvt.key -in ios_dev.pem -name "MyApp" -nodes
  8. Updated the app with the new provisioning and p12 files, then upload to AGOL.
  9. Ran Cloud Make. Received the attached error.
  10. Tried deleting then re-installing the Apple intermediate cert (and IOS developer cert), the followed the above process again. Still no luck.

 

 

When I inspected my provisioning profile in the iOS Dev site, I verified that the new certificate was selected and the profile was for development. But I did notice this message next to the new certificate "For use in Xcode 11 or later" - wonder if that could be related?

 

Any thoughts would be appreciated.

Outcomes