AnsweredAssumed Answered

OrbitGeoElementCameraController - Issues with camera on GeoElement position update

Question asked by Jarrod.bradford on Jun 6, 2019

I'm having a non-deterministic issue with the OrbitGeoElementCameraController that will sometimes cause the camera to flicker randomly on every position update to the provided GeoElement. I'm using the SimpleRenderer and heading, pitch, roll attributes for the renderer scene properties but it also happens without using these attributes.

 

It always appears to snap 45 degrees in the wrong direction before looking at the geo element after a position update. When I manually pan/tilt with the mouse, it will still flicker the same 45 degrees. My source code is largely based around the Animate3DGraphic WPF tutorial.

 

The frustrating thing is that I may run my application 10 times in a row and it behaves as expected with no camera issues when following a selected geo element. Then on the 11th time, it starts flickering again on every position change (currently at 2Hz) so when it happens, the follow feature is largely useless when this bug occurs. Is there anything I can do to help figure out the root cause here?

 

I'm running ArcGIS Runtime 100.5.

 

Edit: I was able to make a small sample app that reproduces the error. Run it, press the follow button, and if it the camera stays still on the geo element, close the app and rerun it. It will reproduce for me consistently every few tries.

 

Note you may need to re-install the nuget package for ArcGISRuntime because it doesn't automatically re-download the ArcGISRuntime100.5 folder to the debug output.

 

Edit: After looking at it more and trying different solutions, it appears to be caused by having a TextSymbol in a DistanceCompositeSceneSymbol and that graphic being the target of the OrbitGeoElementCameraController. Not including the text symbol seems to not induce the bug. This has been the only reliable way I can reproduce it and even still it only happens maybe 1 out of every 10 tries.

Outcomes