AnsweredAssumed Answered

Schema out of date 10.7 client to 10.3.1 SDE Oracle 12c

Question asked by joelhempenius_m on May 20, 2019
Latest reply on Jul 9, 2019 by reinhold.schnizer_TIWAG

My organization is planning to update all Arcgis Software from 10.3.1 to 10.7. I'm currently testing the 10.7 products and I've run into an error with using a small number of tables from my Enterprise Geodatabase from ArcCatalog 10.7 and Arcgis Server 10.7

When I try to get the properties of this table in ArcCatalog, I get a message: Schema out of date, Retry as owner or sdeadmin [THEMA_BAG.VBO_ADRESSEN][STATEID = 90368]

From Arcgis Server I get:

WARNING May 20, 2019, 12:01:54 AM The Layer:'Verblijfsobjecten' in Map:'Layers' is invalid. The base table definition string "THEMA_BAG.VBO_ADRESSEN" is invalid. Schema is out of date, Retry as owner or sdeadmin [THEMA_BAG.VBO_ADRESSEN][STATE_ID = 90368]. Geodiensten/Externe_Data.MapServer 

Arcgis Server was installed with 10.3.1 and the mapservice was created using a 10.3.1 client, after installing and creating the mapservices, I upgraded to 10.7

 

When I run this code in Arcpy from ArcCatalog 10.7:
fields = arcpy.ListFields(r"E:\SDE\geodiensten_view@barp.sde\THEMA_BAG.VBO_ADRESSEN')
print (str(len(fields))), I get 0, so Arcpy can see the table, but it cannot get the fields.

 

Arcmap, ArcCatalog and Arcgis Server 10.3.1 can use the table without any error. 

 

My Enterprise geodatabase contains 1000+ Featureclass, most of them can be used with 10.7 without any problem, there are only around 10 tables which result in the same error and 0 arcpy fields. 

 

The user has only select on the table in both cases.

 

I use Oracle 12c 12.1.0.2.0

Running this code with ArcCatalog 10.3.1 gives:

>>> desc= arcpy.Describe('E:\SDE\geodiensten_view@barp.sde')

>>> desc.currentRelease

True

>>> 

 

Normally, when I get this error, I would use Schema owner to connect in ArcCatalog and hit the table to fix the Schema out of date, but I do this with both client and SDE at the same version.

In this case I'm afraid I might break something on the 10.3.1 side when I use the Schema owner on ArcCatalog 10.7 to connect to this table. The Enterprise Geodatabase contains 1TB+ of data, so restoring the database from backup after I break something is possible, but time consuming. 

 

So my question is: can I solve this Schema out of date with a 10.7 ArcCatalog and is it safe to do for the exiting 10.3.1 clients?

Outcomes