AnsweredAssumed Answered

Why are my Dashboards not loading for others in the group?

Question asked by FranklinCountyPaGIS on May 17, 2019
Latest reply on May 28, 2019 by FranklinCountyPaGIS

I have several dashboards I have collected into a web application for displaying metrics per an Admin request.  As this is protected data, I cannot share the dashboards here.  I have a group that has two others who can access the dashboards, and some of the widgets are loading fine.  However, a lot of the widgets sit and spin forever.  The widgets are pulling data from a rest endpoint on my arcgis server.  The layer contains about 72,000 features.  The widgets are for counts of different attributes, and some of them are not coming through even after 10+ minutes of waiting.  Other services that have 48,000 features on the same server are loading.  

 

These load fine on my computer.  I've got two other people who cannot get the dashboards or application to load.  Developer tools in firefox gave me the following error for one of the users:

 

>>>> Application Fatal Error TypeError: d.setEndValue is not a function _updateChart@ <portal URL>/apps/opsdashboard/assets/nickel-538ad2dd3f01cfd97bc8c065f82d70e6.js:1762:8

 

The console also had an error about running out of memory.  

 

I'm not sure why this is doing this.  Any ideas?  

 

Image attached.  Data that is not loading is the same source displaying in the map.

Recorded performance for user that couldn't load using developer tools & have profile export attached as a JSON if this helps.

Attachments

Outcomes