mscott-esristaff

JTX Post-Install on Windows 7

Discussion created by mscott-esristaff Employee on Jan 7, 2010
Latest reply on May 20, 2010 by tbello-esristaff
All,

If you are having trouble running the JTX 9.4 Beta 1 Post-Installation on Windows 7, UAC may be the culprit.  Here is my platform information:

Windows 7 Enterprise, 64 bit
SQL Server 2008 64 bit
ArcSDE for SQL Server, Advanced/Enterprise

When you get to the screen for creating the connection to the JTX Repository, and click the "Finish" button, you will get an error that pops up in a window that says:

Execption from HRESULT: 0x800A0046 (CTL_E_PERMISSIONDENIED)

The JTX tables will be created in the database, but if I you try to Add JTX Database in ArcCatalog, you will get the same error.

The solutions are as follows:

1.  Drop the User Account Control settings in Control Panel.  I dropped it to the lowest setting, but one notch lower might work.

2.  Run the Post-Install tool as "Administrator"

3.  Use C:\program files\jtx\bin\jtxadvancedsettings.exe to change the Database Folder path to a different location.  You could, for example, create a folder called C:\JTX, then run the post-install tool again.

Mark Scott
ESRI-Boston

Outcomes