arxit20

Issue with relationship class in ArcGIS Enterprise 10.6.1

Discussion created by arxit20 on May 10, 2019
Latest reply on May 10, 2019 by arxit20

Hello,

I'm facing an issue with relationship class in ArcGIS Enterprise :

 

I've created a new project in ArcGIS Pro 2.2.3 with :

- One feature class Origine (with a global ID)

- One feature class Destination1 (with a GUID attribute named f_id)

- One feature class Destination2 (with a GUID attribute named f_id)

- One composite / 1-m relationship class between Origine (GlobalId) > Destination1 (f_id)

- One composite / 1-m relationship class between Origine (GlobalId) > Destination2 (f_id)

See attached file ArcGISPro_01.png

 

In ArcGIS Pro, everything works perfectly, especially when I delete a feature from Origine, linked feature in Destination1 and Destination2 are also deleted.

 

Now, I'm publishing the map in a all-in-one installation of ArcGIS Enterprise 10.6.1 (ArcGIS Server/Portal/Relational datastore). If I try to do the same (i.e. deleting a feature form Origine table), then I can see that only linked feature from the first relationship is deleted ...

See attached files Portal_xx.png

 

it seems that ArcGIS Enterprise does not iterate on all the relationship of the Origine layer, but only consider the first one !?

Is ArcGIS Enterprise support only one composite relationship for an origin table ?

 

I didn't see anything about such a limitation or bug in the ESRI online help or identified issues.

So any help welcome.

 

Thanks 

Julien L.

Attachments

Outcomes