AnsweredAssumed Answered

Map fails to draw after a few minutes of use 10.5.1

Question asked by Drymarchon on Apr 16, 2019

I am experiencing a problem in which my maps stop drawing after a few minutes of use. Refreshing the map does nothing. At first the problem appeared to be connected to the basemap, but that is no longer the case. When the map stops drawing no errors appear. All the tools appear to work, including the magnifying glass and pan, but when the tools are used the map does not change at all. If, however, I then save the mxd, close the program, and open the map again, the map position and scale are updated as if the tools had been working all along (I just couldn't see what they were doing). It was suggested to me to run disk cleanup and clear temporary and system files, and that appeared to fix the problem for a few days, but no longer and disk cleanup doesn't fix anything if I run it again. This problem is affecting multiple maps using different layers, is very frustrating, and has made the software almost unusable to me.

 

Would changing the layers over from shapefiles to a geodatabase improve the problem? I am suspecting that is not the issue here. I have attached an image that shows a partially drawn map that is stuck right now. The entire map should be covered in the white polygons and it won't pan or do anything unless I save and restart, then I've got a few minutes of functionality again. Any ideas? Thank you.

 

Windows 10, core i7-7700 2.80GHz processor with 16GB RAM running ArcGIS Desktop 10.5.1


Outcomes