AnsweredAssumed Answered

Survey123 behaving strange at certain times of the day?

Question asked by ScottEvans_CCG on Apr 12, 2019
Latest reply on Apr 25, 2019 by ScottEvans_CCG

I've been experiencing some weird behavior with regard to Survey123 and time.  This is kind of multi-part issue really, I'm hoping they are somewhat related, but my guess is they are two separate issues.  I'll do my best to describe below.  

 

Issue 1:  Our organization set up a survey where you have two sections where you can manually enter time (although it will auto populate based on the current time): 'Time of Notification' and 'Time of Arrival'.  However, if you select anytime between 12:00 PM and 12:45 PM it presents an error message, stating 'This is a required question.'  Note that for this section, you can only pick 15 minute intervals, so 12:00, 12:15, 12:30, and 12:45 will error out.

 

 

Issue 2: We've set up another survey where it's populating an Excel spreadsheet in SharePoint and sending out email notifications using Microsoft Flow.  Note this one has no manual time entry ... however, it's still recording time on the back end of ArcGIS Online.  This process has been working fine except today I noticed that a survey that was submitted at 1:25 PM did not trigger in Microsoft Flow.  However, Microsoft Flow does not show it as a 'fail', it just flat out did not trigger.  Thus the spreadsheet was not populated nor was an email notification sent out.  I discovered this particular one after poking around the 'stakeholder' point file on ArcGIS Online.   

 

Anyone experienced the behavior described in the scenarios above?  Really it appears the first one is just a back-end Survey123 bug … however, I cannot explain the fault behind the second scenario.  Plus it's just that much more difficult to troubleshoot; I suppose I can keep monitoring the data and making sure both the point file in AGOL match what populates in the spreadsheet.

Outcomes