AnsweredAssumed Answered

JSON To Features "POLYLINE" geometry type

Question asked by GabrielFM on Apr 11, 2019
Latest reply on Apr 16, 2019 by GabrielFM

I imported a GeoJSON using JSON to Features (AGP 2.3.2). Unfortunately there's no option to select the geometry type through the GP dialog box. When I reviewed the documentation for the python code example, I saw that "geometry_type" can convert "POLYLINE". However, according to RFC7946 Section 3.1.4 there is no Polyline type that GeoJSON recognizes. LineString appears to be the equivalent. 

 

As I stepped through the geometry types, seeing if the python snippet would convert the appropriate geometry, I confirmed that it isn't seeing the "LineString" geometry. Specifying Polyline doesn't search for LineString. 

 

Another odd thing I noticed is the tool seemed to "lock on" to a geometry type. I was using the same python

 

arcpy.JSONToFeatures_conversion(r"C:\Users\gmarcus\Downloads\Testing (4).json","TestJSONImportPyPolygon", 'POLYGON') 

 

and 

arcpy.JSONToFeatures_conversion(r"C:\Users\gmarcus\Downloads\Testing (4).json","TestJSONImportPyPoint", 'POINT')

 

but only points were converted. This didn't happen when I first ran the GP tool from the dialog box (converted to polygon by default)

It didn't happen when I ran the python command and first selected polygon.

It only occurred after I ran the python command and selected point. It's stuck on point now. 

Restarting the program results in the same behavior. 

 

Questions:

Has anyone run into this before?

Did you submit a bug request?

Outcomes