AnsweredAssumed Answered

Photo icons not appearing in app in now function is in calculate field

Question asked by monzay on Apr 11, 2019
Latest reply on Apr 11, 2019 by EPolle_TensingInternational

Survey123 Connect v3.3.5.1

Survey123 v3.3.64

 

Note 2: After I posted this (included the Note below) I realized that my had pre-loaded data into the HFS and had used Inbox Refresh to pull it down into the survey. No images were pre-populated. I know that you cannot edit photos this way. The form works perfectly well if I start a new collection. If I look at a pre-existing record that is when I see the issue.

 

I can click on Working twice and the "Take Photo of Reading" icon will appear. The second photo icon for mxu number never appears.

 

Note: I was about to post this when I switched the now() function from the calculation field to the default field. All of the issues I'm reporting here went away. I'm not sure why that would make a difference but it did.

 

Here is the original text:

 

I've seen the posts about the camera icons not showing because of the toolbar text color. This is different.

This is a new survey I'm developing. I'm seeing this issue on both Windows and iOS.

 

 

 

The survey opens with no selection on this question

before selection

 

Choosing Working opens the question for taking a photo. There is no icon

after selection

If I uncheck Working and check it again the icon shows.

not working helps expose icon

 

I have a second photo question that is not based on an conditional logic. It should just appear on the form but it doesn't.

mxu photo

Outcomes