AnsweredAssumed Answered

Copy Raster yields only 3-bands from Hyperspectral Mosaic Dataset (Pro)

Question asked by tyschwartz on Apr 5, 2019
Latest reply on May 17, 2019 by KKramer-esristaff

Hello,

 

I have a Mosaic Dataset of drone-based Hyperspectral (270 bands) imagery.  The data is comprised of multiple flight paths and is sewn together with seamlines that I created. I am using Pro v2.3.2 (Basic License)

 

When exporting the Mosaic Dataset to a merged raster (.img), using the "Copy Raster" geoprocessing tool, the image that is being outputted is only 3 bands - I am losing all of the other bands.  I have tried numerous file types - tif's grids within a gdb, everything outputs the same 3 band imagery, and tried every setting imaginable, including Environment settings. I am exporting as 32 bit float pixel depth (same as the input imagery) and am NOT checking the "Colormap to RGB" box.

 

I have confirmed that the original Mosaic Dataset contains all 270 bands of imagery.  

 

Curiously In ArcMap I am hitting an out of memory error (which makes sense) after the process runs for a good deal of time (an hour maybe).  To me this probably means all the bands are exporting correctly in ArcMap. However, when running in Pro the process finishes quickly and exports only 3 bands.  Same exact settings... 

 

The only conclusion I can come to here is that there is a potential bug where the tool is running as if the "Colormap to RGB"  setting is always checked.

 

Thanks
Tyler

Outcomes