AnsweredAssumed Answered

How do get geopackage layers to display in ArcPro 2.3.0?

Question asked by jgoergen.CALFIRE on Apr 4, 2019
Latest reply on May 28, 2019 by bharold-esristaff

I am trying to load layers from a geopackage into ArcGIS Pro v2.3 to perform some geoprocessing.  When I add the layers to the map they appear in the table of contents, but do not display on the map canvas.  When I try and open the attribute table I get an error, "Shape integrity error" (error image below).  I fixed the geometry of the layers and tried again.  This still resulted in the same error.  When I tried to open the data in ArcMap 10.5.1 everything worked fine - the layers loaded, rendered, and the attribute table was viewable.  Accessing the data also worked perfectly in QGIS 3.4.  Is there a way to get geopackage data to display in ArcPro?  I can geoprocess in other environments but for publishing services to AGOL I would prefer to have the ability to use ArcPro to publish data stored in a geopackage due to the more flexible and complex symbology options available in ArcPro versus ArcMap.   

 

Outcomes