AnsweredAssumed Answered

Field calculator not working in ArcGIS Pro (2.2) with a joined table

Question asked by HeatherTaylorDAFF on Apr 3, 2019
Latest reply on Apr 7, 2019 by Dan_Patterson

I  created a task in ArcGIS Pro 2.1 that updates a field in a feature service in ArcGIS online with the local government area that the point is in. The task performed a spatial join between the feature service (points where disaster impacts had occurred) and the LGA data set, joined the new feature class table back to the original service and then did a 'calculate field'  to update the local government area details in the original service.

 

This worked fine in 2.1 but when I changed to 2.2.4 the task failed. I have also tried running it manually with the separate tools and it fails on the calculate field step. The error message varies: I have had 'error 002536 - does not support or is not in a state to support SQL expressions' and error 999999 'the fields collection contained multiple OID fields'. 

 

Any suggestions?

Outcomes