AnsweredAssumed Answered

Why is editing attribute tables so frustrating?

Question asked by Matth on Mar 28, 2019
Latest reply on Apr 2, 2019 by Matth

I just starting using ArcPro 2.3.1 so I'm still a bit (ok, very) loyal to Desktop. I began with a very simple project: tidy up attributes. Meaning I'm simply fixing spelling, grammar, capitalization, etc. Nothing spatial related.

 

Please understand, I'm not a 'hater' as much as this may come off as one. I'm focusing on making the transition just as I did from ArcView 3.2 to ArcMap. I'll grow to love Pro for what it is, I'm just experiencing these learning curves with a great gnashing of teeth!! I'm currently going thru a Pro book I got online, but skipping ahead I didn't see any help with my issues below.

 

I'm looking for advice from the community!

My problems/gripes are such:

1. I can't freeze fields

2. I tried using the Highlight Field function, but it doesn't work. Tried on 2 PC's and nothing.

3. I sorted one column. When I make a change, it auto re-sorts. Thus I lose my 'place' of where I was simply typing and tabbing to the next field. It's rather distracting.

4. In addition, after the auto re-sort, the field widths revert back to some sort of default width.

5. I can't quickly copy/paste cell contents from one cell to another. I have to select inside the cell and then Ctrl+V. In ArcMap I could go vertically and copy/paste about as fast as I can hit Ctrl+V. Huge bummer.

6. I can't dock the attribute table at the bottom, under all the other pinned and docked windows such as Contents and Pop-up.

7. Using the horizontal scroll bar...Scanning...ugh! I will say I found the Shift+Wheel mouse moves the table horizontally. Although, it's a different scroll acceleration than vertical scrolling. 

8. If I want to change 1 character, such as capitalizing a street name it takes 3 clicks. One to select/focus the cell, one to select text (it highlights all text in cell), one to drop the cursor between characters where I can finally fix the mistake. I believe in Desktop I could do this quicker. Two clicks.

9. I can't type in a cell, hit Enter and then begin typing in the next cell down. I have to click into that next cell...again. But, as above, the table 'regens' and shifts all over again. Argh!!

10. No Find & Replace. It was easy, albeit buggy, in Desktop. I did find the Python examples and got this to work, but it's an extremely slower process. I've already up voted for Find & Replace here in the community forums for future releases.

11. When viewing a small selection set of records in 'Show Selected Records', a wheel scroll should scroll the table horizontally, since there is not enough records to scroll vertically.

12. Highlighting records in a Selected Records view highlights the cells as yellow, just like in Desktop. But when I change a value, the yellow highlighted records are un-highlighted. In Desktop, they stay highlighted.

Outcomes